開発したアプリなど一覧

Rails アプリを動かそうとしたら Please replace therubyracer with mini_racer と言われた

以前 Ruby on Rails で作成した Web サイトをメンテナンスするためにいろいろ作業していたところ、以下のエラーメッセージが表示され正常に動かなかった。

ActionView::Template::Error (ExecJS::RubyRacerRuntime is not supported. Please replace therubyracer with mini_racer in your Gemfile or use Node.js as ExecJS runtime.):

therubyracer ではなく mini_racer を使えということらしい。mini_racer は therubyracer の後継らしい。

以下のように Gemfile の therubyracer を mini_racer に変更し bundle install しよう。

# gem 'therubyracer'
gem 'mini_racer'

通常であればこれだけで動くと思うが、自分の環境では rails s を実行すると以下のエラーが出た。

Please install gem 'therubyracer' to use Less.

less 使って無かったので gem 'less-rails' を削除し、再度 rails s を実行すると正常にサーバーが立ち上がった。

Sponsored Link

コメント