VPS の CentOS に Vim7.3 をインストールした。

シェアする

.vimrcと普段使ってるプラグイン類をサーバにつっこみ vim を起動したら

hoge does not support this version of vim (700).

とかいわれてテンションだだ下がりである。

vim --version してみたらたしかに 7.0 だ。こんなものは使えない、とっとと新しいものにする。しかしこの CentOS では yum からでは最新版はインストールできない。

なのでソースからインストールします。

以下手順。

Sponsored Links

今ある vim をアンインストール

$ sudo yum remove vim vim-enhanced vim-common vim-minimal

ソースコードをダウンロード、解凍

ソースコード本体と日本語のためのなにか。

$ wget ftp://ftp.vim.org/pub/vim/unix/vim-7.3.tar.bz2
$ wget ftp://ftp.jp.vim.org/pub/vim/extra/vim-7.2-extra.tar.gz
$ wget ftp://ftp.vim.org/pub/vim/extra/vim-7.2-lang.tar.gz
$ 
$ tar jxvf vim-7.3.tar.bz2
$ tar zxvf vim-7.2-extra.tar.gz
$ tar zxvf vim-7.2-lang.tar.gz
$ 
$ mv vim72 vim73

make するために必要なパッケージをインストール

ncurses-devel がないと make できないっぽい。

$ sudo yum install ncurses-devel

make install

いつものコマンド

$ cd vim73/src
$ ./configure --enable-multibyte \--with-features=huge \--disable-selinux
$ make
$ sudo make install

できた!

$ vim --version
VIM - Vi IMproved 7.3 (2010 Aug 15, compiled Jan  9 2012 02:12:41)
Compiled by ryomatsu@dti-vps-srv01

これで作業が捗るね!

Sponsored Link

シェアする

フォローする

コメント

  1. jfbcb より:

    well,i just do it as u say,but it doesn’t work !