コメント欄にあってもコンパイルエラーでるんだぜ。

シェアする

javaのsdkを1.4から1.5にかえたら妙なところでコンパイルエラーが出た。全てコメント欄とStringの日本語を指して、「 warning: unmappable character for encoding UTF8」となる。要するにUTF-8で書けってことだ。変換のしかた忘れたから全部英語に書き直したら動くようになった。

しかし1.4はshift_jis使えるのに1.5で使えないとはどうゆうこった。しかもコメント欄も。日本語めんどくせー

Sponsored Link

シェアする

フォローする

コメント

  1. 我猫 より:

    nkf -u(-Uだっけ?)で変換できるので、
    nkf -u ??.java > ??_new.java
    ってやればいけるかな。

  2. jklryo より:

    おー すっかり忘れてた。thx