PHP4.xとpostgresの罠

シェアする

PHPとpostgresを玄箱につっこみテストしてたんだが、うまく動かず。

データベースとの接続はできてるのだが、データ引っこ抜くpg_queryのところで、「pg_queryなんて関数ねぇよ」と言われる。どこのWEBサイトもpg_queryで引っ張ってくるのが多く、試しにphp関係のものをaptitudeで適当に入れても動かず。

ぐぐって見つけたこのサイトに書いてあることが答えだった。Debian GNU/PHP+PostgreSQL/動作確認

PHPのバージョンが違うからpg_queryは使えませんってオチ。
さすがwoody、入ってるソフト古いぜ。

Sponsored Link

シェアする

フォローする